API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DoubleEquality Operator

Compares a double value with a Datatype.Double value.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2022.0.13611
Syntax
public static bool operator ==(
	double Left,
	Double Right
)

Parameters

Left
Type: SystemDouble
The double value to be compared.
Right
Type: Tekla.Structures.DatatypeDouble
The Datatype.Double value to be compared.

Return Value

Type: Boolean
True if the values are the same.
See Also