API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DistanceListConverter Class

The DistanceListConverter class converts types to and from the distance list type.
Inheritance Hierarchy
SystemObject
  System.ComponentModelTypeConverter
    Tekla.Structures.DatatypeDistanceListConverter

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2022.0.13611
Syntax
public sealed class DistanceListConverter : TypeConverter

The DistanceListConverter type exposes the following members.

Constructors
  NameDescription
Public methodDistanceListConverter
Initializes a new instance of the DistanceListConverter class
Top
Methods
  NameDescription
Public methodCanConvertFrom
Checks whether the conversion can be made from the source type to the distance list type.
(Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public methodCanConvertTo
Checks whether the conversion can be made from the distance list type to the destination type.
(Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public methodConvertFrom
Converts an object from the given culture to the distance list type.
(Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public methodConvertTo
Converts an object from the distance list type to the given destination type.
(Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also