API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DistanceToDecimalString Method (String, IFormatProvider, DistanceUnitType)

Converts the distance to a decimal string representation.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2022.0.13611
Syntax
public string ToDecimalString(
	string format,
	IFormatProvider formatProvider,
	DistanceUnitType unitType
)

Parameters

format
Type: SystemString
The format string.
formatProvider
Type: SystemIFormatProvider
The number format provider.
unitType
Type: Tekla.Structures.DatatypeDistanceUnitType
The unit type.

Return Value

Type: String
The string representation of the distance.
Exceptions
ExceptionCondition
ArgumentExceptionThrown if an invalid unit type is specified.
Examples
This example shows how to specify a number format, a format provider and a unit type when converting a Distance instance into a decimal string.
using Tekla.Structures.Datatype;
using System.Globalization;

public class Example
{
       public void Example1()
       {
           Distance.UseUnitsInDecimalString = true;

           // For this demonstration, we'll format 300.2 millimeters.
           Distance distance = new Distance(300.2);

           // Even if the UseFractionalFormat is set to true, we can still get the decimal representation.
           string decimalString = distance.ToDecimalString("0.00", CultureInfo.InvariantCulture, Distance.UnitType.Inch);
       }
}
See Also