API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

UserPropertyItemSetDefaultValue Method (String)

Sets the default value of a string property.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2022.0.13611
Syntax
public bool SetDefaultValue(
	string DefaultValue
)

Parameters

DefaultValue
Type: SystemString
The new value.

Return Value

Type: Boolean
True on success.
See Also