API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

UserPropertyItemAddToObjectType Method

Adds the user property item to the given object type.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2022.0.13611
Syntax
public bool AddToObjectType(
	CatalogObjectTypeEnum objectType
)

Parameters

objectType
Type: Tekla.Structures.CatalogsCatalogObjectTypeEnum
The object type to add the item to.

Return Value

Type: Boolean
True on success.
See Also