API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

MeshItemEnumeratorSelectMeshItem Method

Selects a mesh item in the mesh database with the given name and grade.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2022.0.13611
Syntax
public static MeshItem SelectMeshItem(
	string Name,
	string Grade
)

Parameters

Name
Type: SystemString
The name of the mesh item to select.
Grade
Type: SystemString
The grade of the mesh item to select.

Return Value

Type: MeshItem
The first MeshItem that matches the conditions.
See Also