API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

MaterialItemSelect Method (String)

Selects the material item based on the name from the material database. The material name can also be an alias name.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2022.0.13611
Syntax
public bool Select(
	string materialName
)

Parameters

materialName
Type: SystemString
The name or alias name of the material.

Return Value

Type: Boolean
True on success. False if the material was not found.
See Also