API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

CatalogHandlerImportShapeItems Method

Imports shape geometry items (*.tsc) from specified folder. Import throws exception if model is not open. Import overrides the existing shape items in the catalog without any warnings.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2022.0.13611
Syntax
public bool ImportShapeItems(
	string path
)

Parameters

path
Type: SystemString
The path to be used for import.

Return Value

Type: Boolean
true if successful.
Examples
using System;
using Tekla.Structures.Catalogs;

public class Example
{
       public void Example1()
       {
           if (new CatalogHandler().ImportShapeItems(System.IO.Path.GetTempPath()))
               Console.WriteLine("Shape geometries imported successfully to model.");
       }
}
See Also