API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AnalysisResultDelete Method

Delete analysis results by the given key.

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2022.0.13611
Syntax
public static bool Delete(
	AnalysisResultObjectTypeEnum objectType,
	int objectId
)

Parameters

objectType
Type: Tekla.Structures.AnalysisAnalysisResultObjectTypeEnum
Object type.
objectId
Type: SystemInt32
Object id.

Return Value

Type: Boolean
True if successful.
Examples
Delete all analysis results of part.
var result = AnalysisResult.Delete(AnalysisResult.ObjectTypeEnum.OBJECT_TYPE_PART, analysisPart.PartID.ID);
See Also