API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AnalysisPartAnalysisTypeEnum Enumeration

The analysis types.

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2022.0.13611
Syntax
public enum AnalysisTypeEnum
Members
  Member nameValueDescription
ANALYSIS_TYPE_IGNORE1 The ignore analysis type.
ANALYSIS_TYPE_TRUSS2 The truss analysis type.
ANALYSIS_TYPE_RIGID_DIAPHRAGM3 The rigid diaphragm analysis type.
ANALYSIS_TYPE_TENSION_ONLY4 The tension only analysis type.
ANALYSIS_TYPE_COMPRESSION_ONLY5 The compression only analysis type.
ANALYSIS_TYPE_SHELL6 The shell analysis type.
ANALYSIS_TYPE_SHEAR_WALL7 The wall analysis type.
ANALYSIS_TYPE_BEAM8 The beam analysis type.
ANALYSIS_TYPE_MEMBRANE9 The membrane analysis type.
ANALYSIS_TYPE_PLATE10 The plate analysis type.
ANALYSIS_TYPE_MAT_FOUNDATION11 The mat foundation analysis type.
See Also