API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AnalysisPartUpDirection Property

The up direction of the analysis part (in the global coordinate system). The axis vector (connecting member end nodes) and the up direction vector define the local XY plane of the member. The local Z can be calculated as localZ = localX x UpDirection (cross product), and after this localY = localZ x localX (cross product).

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2022.0.13611
Syntax
public Vector UpDirection { get; set; }

Property Value

Type: Vector
See Also