API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AnalysisModelModalAnalysisProperties Class

The AnalysisModelModalAnalysisProperties class contains information related to analysis model modal analysis properties.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.AnalysisAnalysisModelModalAnalysisProperties

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2022.0.13611
Syntax
public sealed class AnalysisModelModalAnalysisProperties

The AnalysisModelModalAnalysisProperties type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisModelModalAnalysisProperties
Initializes a new instance of the AnalysisModelModalAnalysisProperties class
Top
Properties
  NameDescription
Public propertyModalAnalysisIncludeSelfWeightMass
Indicates whether selfweight mass is included in the modal analysis.
Public propertyModalAnalysisMassLoadGroupDirections
The mass load group directions of the modal analysis.
Public propertyModalAnalysisMassLoadGroupFactors
The mass load group factors of the modal analysis.
Public propertyModalAnalysisMassLoadGroupIds
The mass load group indentifier of the modal analysis.
Public propertyModalAnalysisMaxFrequency
The modal analysis maximum frequence.
Public propertyModalAnalysisModeCount
The modal analysis mode count.
Public propertyModalAnalysisModel
Indicates whether a modal analysis model is used.
Top
See Also