API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AnalysisLoadGroupLoadGroupDirectionEnum Enumeration

The directions of a load group.

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2022.0.13611
Syntax
public enum LoadGroupDirectionEnum
Members
  Member nameValueDescription
DIRECTION_X1 The X direction.
DIRECTION_Y2 The Y direction.
DIRECTION_Z3 The Z direction.
DIRECTION_NEGATIVE_X4 The negative X direction.
DIRECTION_NEGATIVE_Y5 The negative Y direction.
DIRECTION_NEGATIVE_Z6 The negative Z direction.
See Also