API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

TeklaStructuresFilesGetMultiDirectoryFileList Method

Gets a list of files with the given extension from the default search directories.

Namespace:  Tekla.Structures
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2022.0.13611
Syntax
public List<string> GetMultiDirectoryFileList(
	string fileExtension,
	bool fullpath = false
)

Parameters

fileExtension
Type: SystemString
The file extension to be used.
fullpath (Optional)
Type: SystemBoolean
If true, file with full path with extension is returned.

Return Value

Type: ListString
A list of files with the given extension.
See Also