API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

MateriaClientAdapterIsConnectionActive Method

Returns the value whether connection to Materia server is active or not.

Namespace:  Tekla.Structures.TeklaStructuresInternal.MateriaClient
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2022.0.13611
Syntax
public virtual bool IsConnectionActive()

Return Value

Type: Boolean
true if the connection is active, false otherwise

Implements

IMateriaClientAdapterIsConnectionActive
See Also