API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OperationSplit Method (PolyBeam, Point)

Splits the polybeam and creates a new one in the given position.

Namespace:  Tekla.Structures.Model.Operations
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public static PolyBeam Split(
	PolyBeam Object,
	Point SplitPoint
)

Parameters

Object
Type: Tekla.Structures.ModelPolyBeam
The beam object to be split.
SplitPoint
Type: Tekla.Structures.Geometry3dPoint
The position where splitting is executed.

Return Value

Type: PolyBeam
The created polybeam on success, null on failure.
See Also