API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

StoreyDelete Method

Deletes the Building Hierarchy object instance with the given identifier from the model database. TODO: TTSD-37779 Delete won't work with TeklaModel implementation because dotPluginInterface_ci::DeleteObject fails to find id.

Namespace:  Tekla.Structures.ModelInternal.BuildingHierarchy
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public override bool Delete()

Return Value

Type: Boolean
True if the object was successfully deleted.
See Also