API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Rotation3D Constructor (Vector, Vector)

Initializes a new instance of the Rotation3D class.

Namespace:  Tekla.Structures.Model.Geometry
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public Rotation3D(
	Vector axisX,
	Vector axisY
)

Parameters

axisX
Type: Tekla.Structures.Geometry3dVector
The X direction, must be unit.
axisY
Type: Tekla.Structures.Geometry3dVector
The Y direction, must be unit and perpendicular to axisX.
See Also