API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ReinforcementGetRebarComplexGeometries Method

Retrieves a list of physical reinforcing bars (of type ReinforcingBar). These objects contain physical curves in the 3D space of each reinforcing bar as shown in model view. In case rebar polygon clashes with itself, physical points are moved to avoid clashing. ReinforcingBar only differs from RebarGeometry by containing a Polycurve rather than a Polyline.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public List<RebarComplexGeometry> GetRebarComplexGeometries(
	bool withHooks,
	bool withoutClashes,
	bool lengthAdjustments
)

Parameters

withHooks
Type: SystemBoolean
A parameter to determine whether the hook points should be included in the rebar geometry or not.
withoutClashes
Type: SystemBoolean
A parameter to determine whether self-clash avoidance should be included in the rebar geometry or not.
lengthAdjustments
Type: SystemBoolean
A parameter to determine whether rounding and step tapering should be included in the rebar geometry or not.

Return Value

Type: ListRebarComplexGeometry
A list of RebarComplexGeometrys.
See Also