API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ReferenceModelGetReferenceModelObjectGuidsByExternalGuids Method

Gets reference model object guids by external guids.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public List<string> GetReferenceModelObjectGuidsByExternalGuids(
	List<string> externalGuids
)

Parameters

externalGuids
Type: System.Collections.GenericListString
The external guids.

Return Value

Type: ListString
If successful, the reference model object guids.
See Also