API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AnalysisModelGeneralPropertiesModelCreationTypeEnum Enumeration

Defines the model creation type.

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2022.0.13611
Syntax
public enum ModelCreationTypeEnum
Members
  Member nameValueDescription
FULL_MODEL0 Creates an analysis model using the full model.
BY_WORK_AREA1 Creates an analysis model using the selected area.
BY_SELECTED_PARTS2 Creates an analysis model using the selected parts.
BY_SELECTED_PARTS_AND_LOADS3 Creates an analysis model using the selected parts and loads.
FLOOR_MODEL_BY_SELECTED_PARTS_AND_LOADS4 Creates a floor model using the selected parts and loads.
See Also