API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AnalysisObjectPickerPickObjects Method

Prompts the user to pick objects from the model with the given prompt.

Namespace:  Tekla.Structures.Analysis.UI
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2022.0.13611
Syntax
public List<AnalysisObject> PickObjects(
	string analysisModelName,
	AnalysisObjectPickerPickObjectType type,
	string prompt
)

Parameters

analysisModelName
Type: SystemString
The analysis model name.
type
Type: Tekla.Structures.Analysis.UIAnalysisObjectPickerPickObjectType
The type of objects to pick.
prompt
Type: SystemString
The string to display as user guidance.

Return Value

Type: ListAnalysisObject
An enumerator of analysis object instances.
See Also