API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AnalysisObjectPicker Class

The AnalysisObjectPicker class can be used to prompt the user to do manual picks of analysis objects. The methods throw an exception if the user interrupts (cancels) the pick command.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Analysis.UIAnalysisObjectPicker

Namespace:  Tekla.Structures.Analysis.UI
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2022.0.13611
Syntax
public class AnalysisObjectPicker

The AnalysisObjectPicker type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisObjectPicker
Initializes a new instance of the AnalysisObjectPicker class
Top
Methods
  NameDescription
Public methodPickObject
Prompts the user to pick object from the model with the given prompt. Object is either analysis object or model object.
Public methodPickObjects
Prompts the user to pick objects from the model with the given prompt.
Top
See Also