API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

LoftedPlateBaseCurves Property

The curves that define the directrix lines of the lofted plate. A lofted plate is defined by at least to base curves (non empty if they are Polycurve(s)).

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public List<ICurve> BaseCurves { get; set; }

Property Value

Type: ListICurve
Remarks
Only the first two curves will be used for the plate. Additionally, if the base curves are polycurves, only the first geometry of each polycurve will be used.
See Also