API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

GridCylindricalSurface Constructor (Arc, Double, String)

Creates a new grid plane instance taking the plane and label as input.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public GridCylindricalSurface(
	Arc cylinderBase,
	double cylinderHeight,
	string label
)

Parameters

cylinderBase
Type: Tekla.Structures.Geometry3dArc
The base of the cylinder.
cylinderHeight
Type: SystemDouble
The height of the cylinder.
label
Type: SystemString
The label for the grid plane.
See Also