API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ControlArc Constructor (Point, Point, Point)

Creates a new control arc instance taking the 3 points.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public ControlArc(
	Point startPoint,
	Point endPoint,
	Point pointOnArc
)

Parameters

startPoint
Type: Tekla.Structures.Geometry3dPoint
Start point of the arc.
endPoint
Type: Tekla.Structures.Geometry3dPoint
End point of the arc.
pointOnArc
Type: Tekla.Structures.Geometry3dPoint
Point that defines the arc.
Exceptions
ExceptionCondition
ArgumentExceptionThrows when input points are not defined correctly
See Also