API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Arc Constructor (Point, Vector, Vector, Double, Double)

Constructs a new arc geometry

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2022.0.13611
Syntax
public Arc(
	Point centerPoint,
	Vector startDirection,
	Vector startTangent,
	double radius,
	double deltaAngleRadians
)

Parameters

centerPoint
Type: Tekla.Structures.Geometry3dPoint
Center point of the arc.
startDirection
Type: Tekla.Structures.Geometry3dVector
Direction vector pointing from the center towards the start point of the arc.
startTangent
Type: Tekla.Structures.Geometry3dVector
Vector tangent to the arc at its start point, pointing towards the arc.
radius
Type: SystemDouble
Radius of the arc
deltaAngleRadians
Type: SystemDouble
Angle of the arc in radians. From 0 to 2*PI.
Exceptions
ExceptionCondition
ArgumentExceptionThrows when input values are not defined correctly
See Also