API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Arc Constructor (Point, Point, Vector, Double)

Constructs a new arc geometry

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2022.0.13611
Syntax
public Arc(
	Point centerPoint,
	Point startPoint,
	Vector normal,
	double deltaAngleRadians
)

Parameters

centerPoint
Type: Tekla.Structures.Geometry3dPoint
Center point of the arc.
startPoint
Type: Tekla.Structures.Geometry3dPoint
StartPoint point of the arc.
normal
Type: Tekla.Structures.Geometry3dVector
Normal vector of the arc, defines the axis of rotation of the start vector.
deltaAngleRadians
Type: SystemDouble
Angle of the arc in radians. From 0 to 2*PI.
Exceptions
ExceptionCondition
ArgumentExceptionThrows when input values are not defined correctly
See Also