API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

LevelMark Constructor (ViewBase, Point, Point)

Initializes a new instance of the LevelMark class using the default standard attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public LevelMark(
	ViewBase View,
	Point InsertionPoint,
	Point BasePoint
)

Parameters

View
Type: Tekla.Structures.DrawingViewBase
The view where to insert the level mark.
InsertionPoint
Type: Tekla.Structures.Geometry3dPoint
The location where to place the level mark.
BasePoint
Type: Tekla.Structures.Geometry3dPoint
The location where to the level mark points.
See Also