API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AngleListToString Method (IEnumerableAngle, AngleUnitType)

Converts the given angles to a string in the given units

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2022.0.13611
Syntax
public static string ToString(
	IEnumerable<Angle> angleList,
	AngleUnitType unitType
)

Parameters

angleList
Type: System.Collections.GenericIEnumerableAngle
List of angles to convert
unitType
Type: Tekla.Structures.DatatypeAngleUnitType
Input unit type

Return Value

Type: String
The angle list as a string
See Also