API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AngleList Class

This class provides methods to handle lists of angles
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DatatypeAngleList

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2022.0.13611
Syntax
public static class AngleList
Methods
  NameDescription
Public methodStatic memberParse(String)
Parses the given text as an angle list in the current unit type
Public methodStatic memberParse(String, IFormatProvider)
Parses the given text as an angle list in the current unit type
Public methodStatic memberParse(String, IFormatProvider, AngleUnitType)
Parses the given text as an angle list in the current unit type
Public methodStatic memberToString(IEnumerableAngle)
Converts the given angles to a string in the current units
Public methodStatic memberToString(IEnumerableAngle, AngleUnitType)
Converts the given angles to a string in the given units
Public methodStatic memberToString(IEnumerableAngle, String, IFormatProvider)
Converts the given angles to a string with the given parameters in the current unit
Public methodStatic memberToString(IEnumerableAngle, String, IFormatProvider, AngleUnitType)
Converts the given angles to a string with the given parameters in the current unit
Top
See Also