API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BentPlateGeometrySolverModifyBendSurface Method

Modifies the shape of a bend surface section, and updates related polygon sections accordingly.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public ConnectiveGeometry ModifyBendSurface(
	ConnectiveGeometry geometry,
	GeometrySection bendSection,
	BendSurface surface
)

Parameters

geometry
Type: Tekla.Structures.ModelConnectiveGeometry
Reference geometry to modify which contains cylindricalSection.
bendSection
Type: Tekla.Structures.ModelGeometrySection
Geometry section to modify.
surface
Type: Tekla.Structures.ModelBendSurface
The modified bend surface for the section.

Return Value

Type: ConnectiveGeometry
Modified ConnectiveGeometry if command succeeded or geometry otherwise.
Exceptions
ExceptionCondition
ConnectiveGeometryExceptionThrown if could not modify the bend surface.
See Also