API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BentPlateGeometrySolverAddLeg Method (ConnectiveGeometry, Contour, BentPlateBendShape)

Appends a polygon section to ConnectiveGeometry, using the maximal radius for the cylindrical connection, or the maximum cone aperture for conical connection.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2022.0.13611
Syntax
public ConnectiveGeometry AddLeg(
	ConnectiveGeometry geometry,
	Contour polygon,
	BentPlateBendShape bendShape
)

Parameters

geometry
Type: Tekla.Structures.ModelConnectiveGeometry
ConnectiveGeometry used to create a connection with.
polygon
Type: Tekla.Structures.ModelContour
The polygonal contour to add to geometry.
bendShape
Type: Tekla.Structures.ModelBentPlateBendShape
Shape of the bend that connects the leg

Return Value

Type: ConnectiveGeometry
Modified ConnectiveGeometry if command succeeded or geometry otherwise.
Exceptions
ExceptionCondition
ConnectiveGeometryExceptionThrown if could not create or modify ConnectiveGeometry instance.
ArgumentExceptionThrown when geometry is a stand-alone bend geometry, meaning that the first GeometrySection is a BendSurfaceNode.
See Also