API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DrawingHandlerGetModelObjectIdentifiers Method

Gets model object identifiers of the drawing.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public List<Identifier> GetModelObjectIdentifiers(
	Drawing drawing
)

Parameters

drawing
Type: Tekla.Structures.DrawingDrawing
The drawing where objects are fetched.

Return Value

Type: ListIdentifier
List of model object identifiers in the drawing.
See Also