API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

CannotPerformOperationDrawingNotUpToDateException Class

The CannotPerformOperationDrawingNotUpToDateException class defines the exception that is thrown when a user tries to do an operation which requires that the drawing is active.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
[SerializableAttribute]
public class CannotPerformOperationDrawingNotUpToDateException : TeklaStructuresDrawingsApplicationException

The CannotPerformOperationDrawingNotUpToDateException type exposes the following members.

Constructors
  NameDescription
Public methodCannotPerformOperationDrawingNotUpToDateException
Creates a new cannot perform operation drawing not up to date exception instance.
Top
See Also