API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ComponentItemSelect Method (String, Int32, ComponentItemComponentTypeEnum)

Selects the component item from the component database.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2022.0.13611
Syntax
public bool Select(
	string name,
	int number,
	ComponentItemComponentTypeEnum type
)

Parameters

name
Type: SystemString
The name of the component item to select.
number
Type: SystemInt32
The number of the component item to select.
type
Type: Tekla.Structures.CatalogsComponentItemComponentTypeEnum
The type of the component item to select.

Return Value

Type: Boolean
True on success.
See Also