API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PlacingDistanceAttributes Constructor (Double, Double, Double)

Creates a new placing distance attributes instance with the given search margin, minimal and maximal distance.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2022.0.13611
Syntax
public PlacingDistanceAttributes(
	double searchMargin,
	double minimalDistance,
	double maximalDistance
)

Parameters

searchMargin
Type: SystemDouble
The search margin to be used.
minimalDistance
Type: SystemDouble
The minimal distance to be used.
maximalDistance
Type: SystemDouble
The maximal distance to be used.
See Also