API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

WpfReinforcementCatalog Constructor (String, String, Double)

Creates a new instance of the ReinforcementCatalog and will select in the tree the rebar that contains the given parameters (if possible).

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2022.0.13611
Syntax
public WpfReinforcementCatalog(
	string Size,
	string Grade,
	double BendRadius
)

Parameters

Size
Type: SystemString
The size of the rebar to be selected.
Grade
Type: SystemString
The grade of the rebar to be selected.
BendRadius
Type: SystemDouble
The bend radius of the rebar to be selected.
See Also