API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

WpfProfileCatalog Constructor (String)

Initiates a new instance of the control selecting the given profile.

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2022.0.13611
Syntax
public WpfProfileCatalog(
	string Profile
)

Parameters

Profile
Type: SystemString
The profile string that will be selecteed in the dialog.
See Also