API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

WpfOkCreateCancel Class

Interaction logic for WPFOkCreateCancel.xaml
WpfOkCreateCancel
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2022.0.13611
Syntax
public class WpfOkCreateCancel : UserControl, 
	IComponentConnector

The WpfOkCreateCancel type exposes the following members.

Constructors
  NameDescription
Public methodWpfOkCreateCancel
Constructor
Top
Methods
  NameDescription
Public methodInitializeComponent
InitializeComponent
Top
Events
  NameDescription
Public eventCancelClicked
The CancelClicked event is raised when the Cancel button is clicked.
Public eventCreateClicked
The ApplyClicked event is raised when the Apply button is clicked.
Public eventOkClicked
The OkClicked event is raised when the Ok button is clicked.
Top
See Also