API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

WpfMaterialCatalog Constructor (String)

Creates a new instance of the MaterialCatalog and will select the material (if available) in the tree.

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2022.0.13611
Syntax
public WpfMaterialCatalog(
	string Material
)

Parameters

Material
Type: SystemString
The material to be selected in the dialog.
See Also