API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

WpfBoltCatalogStandard Class

The WpfBoltCatalogStandard class represents a control to select the bolt standard using the bolt catalog.

Bolt catalog controls always need to be in pairs, meaning in every dialog there has to be a WpfBoltCatalogStandard and a WpfBoltCatalogSize control.

Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2022.0.13611
Syntax
public class WpfBoltCatalogStandard : ComboBox

The WpfBoltCatalogStandard type exposes the following members.

Constructors
  NameDescription
Public methodWpfBoltCatalogStandard
Initiates a new instance of the control.
Top
Properties
  NameDescription
Public propertyBoltSizes
Returns bolt sizes in catalog based on selected grade
Top
See Also