API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

CustomObservableCollectionTRepopulate Method

CustomObservableCollection repopulator, sends notification about property and collection change.

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2022.0.13611
Syntax
public void Repopulate(
	IEnumerable<T> collection
)

Parameters

collection
Type: System.Collections.GenericIEnumerableT
The collection used in repopulation.
See Also