API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PositionTypeAttribute Constructor (PositionTypeEnum)

The custom attribute [PositionType()] uses this to store the position type to the system. This is not to be used by itself.

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2022.0.13611
Syntax
public PositionTypeAttribute(
	PositionTypeEnum Type
)

Parameters

Type
Type: Tekla.StructuresPositionTypeEnum
The position type.
See Also