API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PluginUserInterfaceAttribute Constructor

The custom attribute [PluginUserInterface(PluginName.UserInterfaceDefinitions.Plugin1)] uses this to store the description of the plug-in user interface to the system. This is not to be used by itself.

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2022.0.13611
Syntax
public PluginUserInterfaceAttribute(
	string description
)

Parameters

description
Type: SystemString
The description of the plug-in user interface in inp format or the name of the dialog class for the PluginFormBase dialog.
See Also