API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PluginBaseInputDefinition Constructor (ArrayList)

Creates a new input definition instance with multiple point or identifier instances.

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2022.0.13611
Syntax
public InputDefinition(
	ArrayList _Input
)

Parameters

_Input
Type: System.CollectionsArrayList
A list of either points or identifiers.
See Also