API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PluginBaseRun Method

The main method of the plug-in. It is called after the input has been defined with DefineInput(). This is the "main" method of the plug-in and should contain all the actual implementation.

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2022.0.13611
Syntax
public abstract bool Run(
	List<PluginBaseInputDefinition> Input
)

Parameters

Input
Type: System.Collections.GenericListPluginBaseInputDefinition
A list of the same format and order as what was returned from DefineInput().

Return Value

Type: Boolean
True on success.
See Also