API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PluginAttribute Constructor

The custom attribute [Plugin("PluginName")] uses this to store the name to the system. This is not to be used by itself.

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2022.0.13611
Syntax
public PluginAttribute(
	string name
)

Parameters

name
Type: SystemString
The name of the plug-in.
See Also