API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

InputObjectDependencyAttribute Constructor (Int32)

The custom attribute [InputObjectDependency(PluginBase.InputObjectDependency Type)] uses this to store a dependency attribute which determines when the plug-in is updated in the system. This is not to be used by itself.

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2022.0.13611
Syntax
public InputObjectDependencyAttribute(
	int Type
)

Parameters

Type
Type: SystemInt32
The type of the input object dependency as an integer.
See Also