API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DrawingPluginBaseInputDefinition Constructor (Identifier, Point, Point, Point)

Creates a new input definition instance with three points.

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2022.0.13611
Syntax
public InputDefinition(
	Identifier viewId,
	Point point1,
	Point point2,
	Point point3
)

Parameters

viewId
Type: Tekla.StructuresIdentifier
The identifier for the view object.
point1
Type: Tekla.Structures.Geometry3dPoint
The first point.
point2
Type: Tekla.Structures.Geometry3dPoint
The second point.
point3
Type: Tekla.Structures.Geometry3dPoint
The third point.
See Also